Email delivery from CareHQ is delayed

Minor incident CareHQ App
2024-10-17 14:31 BST · 3 hours, 41 minutes

Updates

Resolved

Email delivery is now working as expected.

October 17, 2024 · 18:11 BST
Issue

Our email service Mailgun is currently experiencing an issue which is delaying the delivery of email. They are aware of the issue and are in the process of deploying a fix.

October 17, 2024 · 14:31 BST

← Back