Public website is down

Minor incident CareHQ App
2025-11-24 16:54 GMT · 10 minutes

Updates

Resolved

The issue has now been resolved, the public website including help documentation is now available.

November 24, 2025 · 17:04 GMT
Issue

Our public website is currently down. This does not affect the CareHQ application which is available.

November 24, 2025 · 16:54 GMT

← Back